National Student Clearinghouse Potential Security Vulnerability
Incident Report for UC Law SF
Resolved
This incident has been resolved.
Posted Sep 09, 2023 - 16:01 PDT
Investigating
The National Student Clearinghouse (NSC), with whom UC Law SF shares student enrollment data, including some personally identifiable information such as social security number and date of birth, has announced that its files may have been impacted by a major cyber-security event that impacted dozens of organizations worldwide. While NSC has not verified that UC Law SF data was compromised, NSC’s investigation remains ongoing. Our organization will receive further communication from NSC when more information is available, and we will keep you updated.

NSC promptly took measures to protect customer data and applied the relevant security patches and recommendations from the Department of Homeland Security’s Cybersecurity and Infrastructure Security Agency (CISA) and the Federal Bureau of Investigation (FBI).

NSC has developed a Webpage (https://alert.studentclearinghouse.org/) to assist you in better understanding the cyber-security event. To access comprehensive information about NSC’s commitment to privacy, please refer to their privacy commitment page: https://www.studentclearinghouse.org/about/our-privacy-commitment/. In case you notice any suspicious activity related to your accounts, kindly reach out to NSC directly via their support contact form: https://nscsso.my.site.com/student/s/contactsupport

We will continue our efforts to understand any potential impacts to our students and alumni and will communicate as we know more.
Posted Jun 30, 2023 - 11:02 PDT